Skip to main content
Topic: Request for help to migrate user tools from NWC 2.1 to NWC 2.5.5 (Read 3810 times) previous topic - next topic

Request for help to migrate user tools from NWC 2.1 to NWC 2.5.5

Some months ago, I purchased and installed NWC 2.5, which has been upgraded to NWC 2.5.5.
The old (licenced) version of NWC has been lost.

The attached "LEGACY_config_SELECTION.txt" contains some of the "user tools"
which I had built-up / collected over a number of years.

1. I shudder at the thought of having to type in some of those long parameter lists for "GlobalMod"
2. So far,  I couldn't get any of the "Non-official" *.PHP tools to work in NWC 2.5.5.
3. Some of the *.VBS tools are very useful and I would love to be able to use them again.

My PC is XP SP3.

Help to get me going again, will be most appreciated.
(Please spell out, step-by-step, what I must be doing).

Re: Request for help to migrate user tools from NWC 2.1 to NWC 2.5.5

Reply #1
G'day Haymo,
I assume you have installed the user tools starter kit for 2.5?

In my case I have a file called "nwc2UserTools.ini" in "C:\Program Files\Noteworthy Composer 2\Config". 

(Actually, I also have a copy in "C:\Documents and Settings\login_name\Local Settings\Application Data\Noteworthy Software\nwc2" which seems to be a new location for later Windows versions.  In my case, the one in "C:\Program Files\Noteworthy Composer 2\Config" is the active one - you should check both locations to see where yours has been put considering you now have a "clean skin" installation)

That file contains sections labelled:
[ConsoleClipScripts]
[Config]
[Beta Testing]
and
[LUA Testing]

If you copy and paste the [ConsoleClipScripts] section of your attached text file into the active "nwc2UserTools.ini" file then I think you'll have all your tools back OK.

Just be aware of possible duplicates (I think there will be some defaults already there).
I plays 'Bones, crumpets, coronets, floosgals, youfonymums 'n tubies.

Re: Request for help to migrate user tools from NWC 2.1 to NWC 2.5.5

Reply #2
Hi Lawrie,
thanks for your effort -
which applies to people who've arrived at NWC 2.5 via the upgrade path from 2.1.

Unfortunately,
Installing directly from NWC 2.5 gives:
1. An automatic installation of usertools - and NO Starterkit which I can find.

2. C:\Documents and Settings\<user name>\Local Settings\Application Data\Noteworthy Software\nwc2\config\FileMRU.dat

(which I cannot open, nor edit)

3. C:\Program Files\Noteworthy Software\Noteworthy composer 2
            \itrees                       
            \PHP\php.ini
            \SAMPLES
            \Scripts
                  \lib
                  \wx
                  \wxtools
            \Scripts_UNUSED
            \Setups
            \Template

and php.ini contains:

{ PHP

error_reporting  =  E_ALL | E_STRICT
display_errors = On
display_startup_errors = On
date.timezone = "US/Central"
allow_url_fopen = Off
extension_dir = "."
include_path=".;C:\Program Files\Noteworthy Software\NoteWorthy Composer 2\Scripts"
}

............. which leaves me floundering
without any indication  of where my old tools are to be entered.

Re: Request for help to migrate user tools from NWC 2.1 to NWC 2.5.5

Reply #3
For your GlobalMod tools:
With the focus on NoteWorthy Composer, press Alt+F8
A User Tool popup will appear.
GlobalMod.php is in the '.Starter Tools' Group as 'Global Modification (adp)'
Navigate to that and press Alt+C for Copy...
A User Tool Description popup will appear. Using copy automatically selects the 'Input Type' and 'Options' that the tool expects.

Select what Group you want or create a new group. This works just like the Group: box in  General Staff Properties.

Using this line as a guide:
Quote from: LEGACY_config_SELECTION.txt
Barline_HIDE='php\php.exe Scripts\adp_GlobalMod.php Bar Visibility=Never'
The Name: will be:
Quote from: LEGACY_config_SELECTION.txt
Barline_HIDE

The Command: will be:
Quote from: LEGACY_config_SELECTION.txt
php\php.exe Scripts\adp_GlobalMod.php Bar Visibility=Never
Copy and paste are your friend here.

This method should work for any tools that are packaged with the download from NoteWorthy Composer 2 User Tools

Life becomes more complicated for tools written by others...
Instead of the Copy... button, the Browse... button will be used.
Alt+R (Browse...) opens a standard Open file dialog popup.
This dialog will always default to your Scripts folder. Tools can be located anywhere, but if you put them in the Scripts folder, they are easier to find.

For PHP tools (*.php and *.wxphp):
Using this line as a guide:
Quote from: LEGACY_config_SELECTION.txt
Tripletise='php\php.exe Scripts\tripletise.php 8 d16 d16 16'
the first step is to make sure that tripletise.php is in your Scripts folder.

With the focus on NoteWorthy Composer, press Alt+F8
A User Tool popup will appear.
Press Alt+N for New...
Select what Group you want or create a new group.
Press Alt+R for Browse...
Select: tripletise.php and Open it.
The Name: will be:
Quote from: LEGACY_config_SELECTION.txt
Tripletise
The Command: will be filled out for you, but you will need to add:
Quote from: LEGACY_config_SELECTION.txt
8 d16 d16 16

Browse may not select the 'Input Type' and 'Options' that the tool expects.
See the docs that came with the Tool. Sometimes, inspecting the initial comments in the PHP file will guide you.

For tools written in other script languages, you must know what program is used to interpret the script. This gets added to the beginning of Command: after you have opened the file via Browse...

For tools written in VBScript (*.vbs) or JScript (*.js) either
Quote
WScript
or
Quote
CScript //nologo
will be used.

So, for:
Quote
MakeChord-LP-2='wscript Scripts\MakeChord-LP-2.vbs <PROMPT:Enter the required intervals separated by spaces:=*>
you will first want to insure that MakeChord-LP-2.vbs is in your Scripts folder.
Proceed as above, using New..., making the Name:
Quote from: LEGACY_config_SELECTION.txt
MakeChord-LP-2
and the Command:
Quote from: LEGACY_config_SELECTION.txt
wscript Scripts\MakeChord-LP-2.vbs <PROMPT:Enter the required intervals separated by spaces:=*>
This will also work:
Quote from: me
CScript //nologo Scripts\MakeChord-LP-2.vbs <PROMPT:Enter the required intervals separated by spaces:=*>
Registered user since 1996

Re: Request for help to migrate user tools from NWC 2.1 to NWC 2.5.5

Reply #4
Rick,
Thanks for the very comprehensive reply.


Re: Request for help to migrate user tools from NWC 2.1 to NWC 2.5.5

Reply #5
Rick,
DOUBLE THANKS! for the wonderful step-by-step explanation.

(It looks a bit daunting on just staring at it - but works beautifully when actually DOING the steps.)

I've already migrated most of the urgently needed *.PHP and *.VBS tools to NWC2.5.5.