Skip to main content
Topic: Opening files (Read 9099 times) previous topic - next topic

Opening files

I have been using Noteworthy for years and up to this week when I opened files they were always sorted in name order.  All of a sudden the order has defaulted to date modified order.  Can anyone help me restore the default to name order?

Re: Opening files

Reply #1
Sounds like a function of the operating system rather than NWC.  If you click on "open file", the last icon on the top row of the "Open" window should be the "View Window".  If you select and choose "Details", you can select "Name", "Size", "Date", or "Type" to produce a list sorted how you want.  After you select a file, the next time you use this window it will open (and sort) the same way.
Since 1998

Re: Opening files

Reply #2
Okay, I also have a question about opening files.
I used to be able to "lasso" six or seven (or whatever) files on the desktop or in a folder, using a right-click, and then choosing "Open."  This would open all of the NWCs in the same window, and then I could shift between them using Shift+F6.  Now if I do that, each file opens in its own window, and what's worse, only the first one to open is able to play (the others will "chase" but there is no sound - the MIDI player is otherwise occupied, or something like that).  Is this a function of NWC, or the operating system?  And can I fix it?

TIA

Re: Opening files

Reply #3
Orson: I haven't tried do do what you are doing, but for clarification: Is your operating system XP? With or without various updates?

The reason I ask is that under certain circumstances, it seems that audio control is not immediately released in XP. The technical issue is over my head, but Microsoft knows about it.

Re: Opening files

Reply #4
Thanks Warren, but my last icon on the "Open" window is "details" - I don't have a "View window" icon.  Orson, you are meant to be helping me - not asking for your own help!!!

Re: Opening files

Reply #5
There is no "View Window" icon in any version of Windows I've worked with with. However, from the menu bar at the top, you can first click "View" then click "Arrange Icons" which offers you the choice of whether to arrange icons (file names) by name (filename), type (extension, .***), by size (how many bytes does the file take up), or by date (date created or modified).  The window should open with icons sorted per your choice the next time you open it. HTH

Re: Opening files

Reply #6
Robert A.:  My operating system is Me (which I believe I have read you think is no good, or immediately obsolete, or something, but that's what came with the machine...).
Before that I had 95.

Jan: It is perfectly legitimate for other members of this forum to ask for additional help in a thread related to a problem that they are having.

Re: Opening files

Reply #7
'my last icon on the "Open" window is "details" - I don't have a "View window" icon.'

Jan: Which operating system are you using?
Since 1998

Re: Opening files

Reply #8
Jan wrote:
"the order has defaulted to date modified order. Can anyone help me restore the default to name order?"

I don't know how to change the default, but the order can be changed each time the Open dialog appears by right clicking in the file list and choosing "Arrange Icons," at least using Windows 98 SE. Also try this article.

Orson wrote:
"each file opens in its own window, and what's worse, only the first one to open is able to play (the others will "chase" but there is no sound - the MIDI player is otherwise occupied, or something like that)."

Multiple files open for me as documents in one instance/window of NWC using Windows 98 SE (Shift+F6 has no effect, however). Perhaps using multiple instances/windows is an advanced feature of the version of Windows (Explorer) you are using.

Concerning only the first instance playing, is there a message box before the others start to "chase" saying "One or more of your selected MIDI devices are failing to open. Would you like to go to the MIDI options tab to investigate?" If so, try changing the "Port Usage:" section of the MIDI options tab to something other than "Always." You may have to close all but one instance of the program to do this. The tab can be accessed any time from Menu: Tools|Options|Midi.

Re: Opening files

Reply #9
Orson - Lighten up, I was teasing you!

Re: Opening files

Reply #10
Jan - Sorry, I could not tell by the tone of your voice.

Re: Opening files

Reply #11
Thanks Brian, your "this article" link worked and I have now been able to reset my default.  Thanks to the rest of you too for your help - Orson I thought 3 exclamation marks might have given you a clue. (!!!)

Re: Opening files

Reply #12
3 exclamation marks could have meant really annoyed...

Re: Opening files

Reply #13
I had something similar happen once on my Win98 system.  It wasn't in Noteworthy, but for some reason, right after I installed MS Office 2000, all the "Save as..." dialogs started displaying files in date order instead of alphabetical order.  It was annoying as - well, annoying as MS can be.  And I never found a way to change the default - nothing I did with folder display from the desktop had any effect.

Eventually it went away:  one day I woke up and the "Save as" order was back the way I liked it.  Never will understand MS.

- seb

Re: Opening files

Reply #14
Come to think of it, maybe it was "Open File..." after all.

- seb

Re: Opening files

Reply #15
I know, how can these things resolve themselves on their own? I have windows 98 and every few months it decides it needs a password to open, I do all the right things including deleting the pwl file etc, give up and then in it's own time everything is ok again.  If it happens again just go to Explorer sort your files as you would like them then hold down the control key as you exit and that makes the default - thank again Brian for that.

Orson  I only have one word - !!!

Re: Opening files

Reply #16
That sorting thing goes away over time because it is made to be like that - or actually it is so beacuse Windows stores only a limited amount of Explorer folder view settings. After you have viewed enough folders, the ones that haven't been opened for a while will eventually lose their settings and become what is the default.

Re: Opening files

Reply #17
Re reply 2 Orson's problem - losing sound when running more than one session of NWC:

I run Win98 - my experience has always been that you can open and run NWC several times (don't know why you'd want to, but it happens) - the sound works fine on the first session to have been opened, but it takes control over the sound gizmos, and the second, third, fourth sessions can't run the thingamebobs and doohickeys needed for sound.

Sorry for the technical language.

I used to have Windows ME but upgraded bigtime by reverting to Win98 which I had before - I find it much more stable - I'm annoyed that I spent the money to upgrade to ME in the first place.

Re: Opening files

Reply #18
...don't know why you'd want to...
What I used to do with Win95 was go to the folder containing all 17 parts for a jazz ensemble and open all of them in one swell foop so that I could print the parts, bring them to rehearsal, and play it.  Now I have to open all 17 parts one at a time, from the NWC "browser" window (ctrl+O).  That takes much longer and is very annoying.
And I'm pretty much stuck with ME...

Re: Opening files

Reply #19
Orson, try this:

From Explorer, hold the CNTL key and click on the NWC files you want to open, in order to select them (highlight them). (If the directory contains only NWC files and you want to open all of them, simply select one of them then press CNTL A to select all.) Right-click, Open. Should launch NWC and spawn as many windows as you have files selected.

Works on 95 and 98SE, should work fine in all versions AFAIK.

Re: Opening files

Reply #20
...spawn as many windows as you have files selected.
That's what is does, all right, but I want all of the files to open in one window.
If there are many windows, only the first one is playable:
One or more of your MIDI devices failed to open.
Would you like to go to the properties tab to investigate? [not necessarily verbatim]

 

Re: Opening files

Reply #21
OK. The root cause of this problem is that Windows only allows one client at a time to use any given midi device. There are ways around it, the best is "Hubi's Midi Cable" (google on it if interested) which will let you do strange things like play more than one midi file at the same time.

Before resorting to that, however, try this. Go to Tools | Options | Midi Tab | Port Usage pulldown. Set to "While Playing". Now open a few windows, and see if they're all playable. (Note: you can still only play one at a time, of course.)

Re: Opening files

Reply #22
But, the thing is, I want all of them to open in one window, regardless of the playback function.  I get 17 (or 18 if I open the score also) windows, with 17 tiny icons on the task bar.  I guess I'll just have to open NWC and then open all 17 files one at a time (what a pain).

Re: Opening files

Reply #23
Orson: NWC automatically configures itself so that all NWC files open in the same instance. If each NWC file that you open starts a new NWC instance, then you have altered the standard setup for NWC file associations on your system.

You can get back the standard NWC file associations by reinstalling, or otherwise restoring the file association for NWC files.