Skip to main content
Topic: Extra spacing for longer notes (Read 2189 times) previous topic - next topic

Extra spacing for longer notes

I'm having a problem with Noteworthy Composer 2.75a.2 and would love to get some advice. I want to turn off the option for extra spacing for longer notes. On the File dropdown menu I select Page Setup and uncheck the box for the option for extra spacing, but it has no effect - in edit or any other onscreen mode and on the printed page the space following the notes of longer durations is proportional to the duration of each note. Turning the option on or off has no effect. I'm trying to turn it off so the staffs require less horizontal space when printed. Is there a higher level option that is preventing the one I'm using from taking effect?

Re: Extra spacing for longer notes

Reply #1
Hi Sam,
to confirm, you go to |File|Page Setup...|Options (tab)| and remove the check mark from "Increase spacing for longer notes"?

I figure you have this correct but it doesn't hurt to make sure.

AFAIK this is the ONLY place that needs to be changed, however, if you have forced system breaks anywhere they might be masking the change.  So I would also check that the final barline on any staff does not have a "Force system break" check, ditto Boundary objects that start a new system.

Also, don't forget that this change is current song file specific.  It will NOT affect any other song, nor will it affect any new song unless you modify your template(s).  It will also not affect any new song that does not use a template.
I plays 'Bones, crumpets, coronets, floosgals, youfonymums 'n tubies.

Re: Extra spacing for longer notes

Reply #2
(I was typing this when Lawrie replied.) I have the same version, and I just tested this. It seems to work as expected for me. I assume you have double checked that it actually became unchecked. But there are other things which affect note spacing. If there are multiple staves, the notes align between staves. I.e., if a measure on one staff has 4 eighth notes, and the corresponding measure in another staff has a half note, the half note will take extra space to align with the eighths. Also, lyrics will affect note spacing. Spacing, I think, will normally be one note width between notes. That can be manually shrunk by inserting spacers between the notes. Default for a spacer is one-half a note width but can be shrunk to zero by editing its properties. Of course, spacing cannot be shrunk if another staff, or lyrics, prevents it. I am hardly an NWC expert, so perhaps someone else with more experience can explain further.

Correction: when using spacers, note spacing can be decreased such that lyrics collide with each other.

Re: Extra spacing for longer notes

Reply #3
You might want to experiment with nwc-scriptorium.org/wp/spacerorg.html. It starts with adding "default" spacers that do nothing, but then you can use the tool to add or take away space between notes. It has to be open at the same time your NWC piece is open since you will be doing a lot of cut and pasting on your clipboard.

Thanks again to Rick for hosting this.
Since 1998

Re: Extra spacing for longer notes

Reply #4
Thanks to all of you. My problem might be that I did not use a template, just added staves - two treble and one bass (with the tenor part only) for layering, and bracketed them together. Since I didn't find a template or 3-part harmony (a capella) I just built the staffs from the ground up. If the note spacing option is only active within a template, that could be the problem. I'll fool around with it and see what happens.

Re: Extra spacing for longer notes

Reply #5
If the note spacing option is only active within a template
No, it isn't. You can switch it on or off at wish anytime.
Simply, if you don't use a template that has it switched off it's on by default.

Re: Extra spacing for longer notes

Reply #6
Turning INS off in each (non-templated file) worked for me in a test file just now. 

To pedantically paraphrase what Flurmy said is that Increase Note Spacing is the default behaviour.  If you don't want it, you must turn it off on every file unless you begin with a template which already has it turned off.

There's a reason to increase the note spacing, so an alternative might be to decrease the Staff Metrics in the Fonts tab of the Page Setup tab. Size 14 might be a bit small if you're writing for older instrumentalists, but vocalists can hold the music a bit closer.