Skip to main content

Topic: Windows Media Player: no sound when playing midi files (Read 1145 times) previous topic - next topic

Windows Media Player: no sound when playing midi files
I can't play my midi-files anymore. I use Windows Media Player. It starts up and starts the song, but produces no sound.
Last time I used it, it did work well, but that's a few months ago.
So could it be because of a Windows 10 update or an NWC update ?
Always look on the bright side of life!

Re: Windows Media Player: no sound when playing midi files
Reply #1
I imagine that it's the Windows 10 creators update.

They did quite a bit of work with sound and audio processes. In my case, it cured a problem I was having that I actually thought was a hardware problem.  However, you do a Google search for "Windows 10 creators update audio not working", you will see that there are many problems with the update from an audio point of view.
  • Last Edit: 2017-09-06 06:22 am by Richard Woodroffe
Rich.

Re: Windows Media Player: no sound when playing midi files
Reply #2
I imagine that it's the Windows 10 creators update.

They did quite a bit of work with sound and audio processes. In my case, it cured a problemWM I was having that I actually thought was a hardware problem.  However, you do a Google search for "Windows 10 creators update audio not working", you will see that there are many problems with the update from an audio point of view.

I have no problem with sound in general, and Windows Media Player has no problem with mp3 files. It's WMP + midi that doesn't work anymore.
Always look on the bright side of life!

Re: Windows Media Player: no sound when playing midi files
Reply #3
Remember: MIDI files aren't sound files, they're a set of instructions to the sound card to produce sounds. They have to go through an interpreter, Win10 has messed with what used to be the standard Windows MIDI interpreter, and according to reports it has caused all sorts of problems. I'm no expert at all - I'm still on Win8.1 (and intend to stay with it as long as possible) - but, as Rich said, there are plenty of experts on line to draw on. Someone will have the answer.

Re: Windows Media Player: no sound when playing midi files
Reply #4
NWC would not impact this.

In my experience, Windows has a bad habit of losing its GS Wavetable Synth. Is it still present on your system? If not, you have to reinstall it, which usually involves some kind of triggering of a sound setup reinstall: Settings -> Search for Sound

Re: Windows Media Player: no sound when playing midi files
Reply #5
When I look at Tools/Options/Midi Tab in NWC I can see 'GS Wavetable Synth' and I can play my songs.
So the problem must be Windows Media Player which produces no sounds when 'playing' midi files.
Always look on the bright side of life!

Re: Windows Media Player: no sound when playing midi files
Reply #6
Might be worth trying another player. There are plenty of options available. I find that VLC Media Player works pretty well, and it also plays a few formats WiMP won't, such as flv files.

Re: Windows Media Player: no sound when playing midi files
Reply #7
VLC gives following error (translated from Duth by me, see attachment):
Quote
Codec not supported:
VLCcouldn't decode the format "MIDI" (MIDI Audio)
Always look on the bright side of life!

Re: Windows Media Player: no sound when playing midi files
Reply #8
Sorry. A check of the website suggests that they dropped MIDI support due to undisclosed "security issues." <sigh>

Re: Windows Media Player: no sound when playing midi files
Reply #9
I like Van Bascos Karaoke player for MIDI - pretty sure it still works for 10...

http://www.vanbasco.com/karaokeplayer/
I plays 'Bones, crumpets, coronets, floosgals 'n youfonymums - gonna lern tubies next

Re: Windows Media Player: no sound when playing midi files
Reply #10
As well as using NWC, I use Finale 2011. On my Windows 10 laptop I installed the 2.75a update and now Finale will not play any Finale files (through MIDI). Does anyone know of a conflict? I have done the same on my Win 7 desktop and all is OK.

Re: Windows Media Player: no sound when playing midi files
Reply #11
I like Van Bascos Karaoke player for MIDI - pretty sure it still works for 10...

http://www.vanbasco.com/karaokeplayer/

It took me some time to find the setup window to choose the MIDI output, but now it works perfectly!
It even shows the lyrics (it's a karaokeplayer afer all). But I wonder: if I have different lyrics on different staffs (channels), can I choose which one is showed? I'm planning to look for it myself but now my grandchildren are asking for priority.
Always look on the bright side of life!

Re: Windows Media Player: no sound when playing midi files
Reply #12
<snip> But I wonder: if I have different lyrics on different staffs (channels), can I choose which one is showed?
<snip>
I think it will mix all the lyrics together - it isn't really that smart ;)
I plays 'Bones, crumpets, coronets, floosgals 'n youfonymums - gonna lern tubies next

Re: Windows Media Player: no sound when playing midi files
Reply #13
I think it will mix all the lyrics together - it isn't really that smart ;)
If you know a midi file will be used on Van Basco, only have one staff with lyrics.
Since 1998

Re: Windows Media Player: no sound when playing midi files
Reply #14
This is perhaps a silly question, but did you try using the free Noteworthy Viewer as your MIDI player?  I've tried it with a small number of MIDI files I have, and it seems to play them fine, with the added bonus that you can watch the music scroll by as it plays.

One small caveat: if I have the viewer preconfigured with the FluidR3_GM soundfont, I can load and play a MIDI file and it uses the soundfont driver. However, when I tried to switch to soundfont after loading a MIDI file, the viewer crashed on me (once).

Also, I don't know if the MIDI import process does any quantization / correction to the MIDI file when it loads (as occurs when you import a MIDI file in NWC)

Re: Windows Media Player: no sound when playing midi files
Reply #15
The Viewer performs the raw MIDI file, although it does ignore sysex, if present.

Feel free to post a crash report on the soundfont issue.