Skip to main content
Topic: NWC MIDI sound on Ubuntu 20.04 ? (Read 156 times) previous topic - next topic

NWC MIDI sound on Ubuntu 20.04 ?

I have followed several sets of instructions; NWC 2.75a.2 installs and runs, graphics and fonts work great.  Timidity ports show up, have selected them.  Timidity works fine, responds to aplaymidi.  But NWC doesn't send a peep to Timidity.  Anyone have suggestions?

Re: NWC MIDI sound on Ubuntu 20.04 ?

Reply #1
Dear Jonathan,

I have tested NWC in Ubuntu several years ago but I wasn't happy with the result.

After long hours struggling I was finally able to get NWC running and playing sound, but for some unknown reason it didn't work anymore a week later. After searching several hours it worked again, but because of what I call "instability" (to avoid calling it "my stupidity") I decided to stay on Windows (mainly because of NWC).

What I remember is that I first installed WINE and Timitidy, and in Wine I installed NWC.
Just like under Windows, I had to select a play device (Timidity) in the NWC configuration (TOOLS-OPTIONS-MIDI).

Of course now we are several years later and stuff can be easier today.

Unless you didn't configure NWC correctly, I fear there is little I can help you with.

Bart

Re: NWC MIDI sound on Ubuntu 20.04 ?

Reply #2
Bart, thanks for writing, that does help a lot.  Recently I received a suggestion that the LTS versions of Ubuntu are very stable indeed, whereas the others aren't; so far this has carried well, I used MX Linux on desktop for a number of years.  The only thing that is not working now, is NWC MIDI :-)  Timidity is in, working, and recognized as present in NWC-in-wine, and NWC even says that it is working, it does play, there's just no actual tone.

I do hope and pray for a resurgence in development in NWC, there's nothing like its intuitive setup and keyboard note-entry.

Re: NWC MIDI sound on Ubuntu 20.04 ?

Reply #3
On Windows, when the sound pipeline does not work, I look a the byte counter of my virtual MIDI cable  - this helps me to understand whether the problem is before the cable (NWC, i.e. MIDI generation) or after (my DWS, e.g. Reaper):
  • When I play a piece and the counter increases -> MIDI commands are sent out, problem is at receiving end.
  • No counter increase -> NWC is silent (muted staff, ...).

Maybe this is also possible on Linux.
I have no idea about Linux, but here are two links that seem to give reasonable information that might be helpüful:

http://www.tedfelix.com/linux/linux-midi.html
https://askubuntu.com/questions/526275/is-there-any-virtual-midi-loopback-solution-for-ubuntu-linux

H.M.

Working well! Re: NWC MIDI sound on Ubuntu 20.04 ?

Reply #4
Wow, it was simple!  Here's the sum total of steps:

  • Installed default Ubuntu-native non-snap non-development wine.  This is wine 5.0, which according to winehq is a lot older than they like, but I wanted to run using minimum changes to the distro for now.
  • Install NWC with Wine.
  • Try running NWC.  No sound. 
  • Opened the MIDI options (Tool > Options > MIDI), selected the single available playback device "Midi Through Port-0".  No sound.
  • Installed Timidity with 'apt install timidity'.  It automatically set up to run using ~/.config/autostart/timidity.desktop .  Rebooted.
  • Ran NWC.  No sound.
  • Opened the MIDI options (Tool > Options > MIDI), added the rest of the available playback devices, "TiMidity - TiMidity port 0" through port 3.  No sound.
  • Edited ~/.config/autostart/timidity.desktop .  Third line was "Exec=timidity -iA".  Changed it to "Exec=timidity -iA -Os".  Logged off and logged on
  • Used apt to install the OSS wrapper for ALSA, package "alsa-oss".
  • Started NWC and loaded a score.  No sound.
  • Opened the MIDI options (Tool > Options > MIDI), de-selected the playback device "Midi Through Port-0", leaving the "TiMidity" devices in place.
  • Sound working very well!

 

Re: NWC MIDI sound on Ubuntu 20.04 ?

Reply #5
I'm not THAT sure that this simplicity doesn't contain some fair amount of sarcasm ... but anyway, nice you did it! (Others will find this helpful, I assume).

H.M.