Skip to main content

Topic: Automatic Beam Question (Read 2743 times) previous topic - next topic

Automatic Beam Question
The following has not yet been beamed. When you select Automatic Beam, the two sixteenths at the start of the second strain do not beam. Is that because it is not a full measure? Using V2.5.2.

Code: (nwc) [Select · Download]
!NoteWorthyComposerClip(2.5,Single)
|Clef|Type:Treble
|Tempo|Tempo:90|Pos:8|Visibility:Never
|Key|Signature:F#|Tonic:G
|TimeSig|Signature:6/8
|Note|Dur:8th|Pos:-4
|Bar
|Note|Dur:8th|Pos:-1|Opts:Stem=Up
|Note|Dur:8th|Pos:0|Opts:Stem=Up
|Note|Dur:8th|Pos:-1|Opts:Stem=Up
|Note|Dur:8th|Pos:-1|Opts:Stem=Down
|Note|Dur:8th|Pos:0|Opts:Stem=Down
|Note|Dur:8th|Pos:2|Opts:Stem=Down
|Bar
|Note|Dur:16th|Pos:3|Opts:Stem=Down
|Note|Dur:16th|Pos:4|Opts:Stem=Down
|Note|Dur:8th|Pos:5|Opts:Stem=Down
|Note|Dur:8th|Pos:0|Opts:Stem=Down
|Note|Dur:4th|Pos:-1
|Note|Dur:8th|Pos:1
|Bar
|Note|Dur:8th|Pos:0|Opts:Stem=Up
|Note|Dur:8th|Pos:-1|Opts:Stem=Up
|Note|Dur:8th|Pos:0|Opts:Stem=Up
|Note|Dur:8th|Pos:-2|Opts:Stem=Up
|Note|Dur:8th|Pos:-1|Opts:Stem=Up
|Note|Dur:8th|Pos:0|Opts:Stem=Up
|Bar
|Note|Dur:8th|Pos:0|Opts:Stem=Up
|Note|Dur:8th|Pos:-1|Opts:Stem=Up
|Note|Dur:8th|Pos:0|Opts:Stem=Up
|Note|Dur:4th|Pos:-2
|Note|Dur:8th|Pos:-2
|Bar
|Note|Dur:8th|Pos:1|Opts:Stem=Down
|Note|Dur:8th|Pos:0|Opts:Stem=Down
|Note|Dur:8th|Pos:1|Opts:Stem=Down
|Note|Dur:8th|Pos:2|Opts:Stem=Down
|Note|Dur:8th|Pos:3|Opts:Stem=Down
|Note|Dur:8th|Pos:2|Opts:Stem=Down
|Bar
|Note|Dur:8th|Pos:3|Opts:Stem=Down
|Note|Dur:8th|Pos:4|Opts:Stem=Down
|Note|Dur:8th|Pos:3|Opts:Stem=Down
|Note|Dur:4th|Pos:6
|Note|Dur:8th|Pos:5
|Bar
|Note|Dur:8th|Pos:3|Opts:Stem=Down
|Note|Dur:8th|Pos:2|Opts:Stem=Down
|Note|Dur:8th|Pos:1|Opts:Stem=Down
|Note|Dur:8th|Pos:0|Opts:Stem=Down
|Note|Dur:8th|Pos:1|Opts:Stem=Down
|Note|Dur:8th|Pos:2|Opts:Stem=Down
|Bar
|Note|Dur:4th|Pos:3
|Note|Dur:8th|Pos:-1
|Note|Dur:4th|Pos:-1
|Bar|Style:MasterRepeatClose|XBarCnt:Y
|Bar|Style:MasterRepeatOpen|XBarCnt:Y
|Note|Dur:16th|Pos:4|Opts:Stem=Down
|Note|Dur:16th|Pos:5|Opts:Stem=Down
|Bar
|Note|Dur:4th|Pos:6
|Note|Dur:8th|Pos:-1
|Note|Dur:8th|Pos:-1|Opts:Stem=Up
|Note|Dur:8th|Pos:0|Opts:Stem=Up
|Note|Dur:8th|Pos:-1|Opts:Stem=Up
|Bar
|Note|Dur:4th|Pos:6
|Note|Dur:8th|Pos:-1
|Note|Dur:4th|Pos:-1
|Note|Dur:8th|Pos:4
|Bar
|Note|Dur:4th|Pos:5
|Note|Dur:8th|Pos:-2
|Note|Dur:8th|Pos:-2|Opts:Stem=Up
|Note|Dur:8th|Pos:-1|Opts:Stem=Up
|Note|Dur:8th|Pos:-2|Opts:Stem=Up
|Bar
|Note|Dur:8th|Pos:0|Opts:Stem=Up
|Note|Dur:8th|Pos:-1|Opts:Stem=Up
|Note|Dur:8th|Pos:0|Opts:Stem=Up
|Note|Dur:4th|Pos:-2
|Note|Dur:8th|Pos:-1
|Bar
|Note|Dur:8th|Pos:1|Opts:Stem=Down
|Note|Dur:8th|Pos:0|Opts:Stem=Down
|Note|Dur:8th|Pos:1|Opts:Stem=Down
|Note|Dur:8th|Pos:2|Opts:Stem=Down
|Note|Dur:8th|Pos:3|Opts:Stem=Down
|Note|Dur:8th|Pos:2|Opts:Stem=Down
|Bar
|Note|Dur:8th|Pos:3|Opts:Stem=Down
|Note|Dur:8th|Pos:4|Opts:Stem=Down
|Note|Dur:8th|Pos:3|Opts:Stem=Down
|Note|Dur:4th|Pos:6
|Note|Dur:8th|Pos:5
|Bar
|Note|Dur:8th|Pos:3|Opts:Stem=Down
|Note|Dur:8th|Pos:2|Opts:Stem=Down
|Note|Dur:8th|Pos:0|Opts:Stem=Down
|Note|Dur:8th|Pos:-1|Opts:Stem=Down
|Note|Dur:8th|Pos:0|Opts:Stem=Down
|Note|Dur:8th|Pos:2|Opts:Stem=Down
|Bar
|Note|Dur:4th|Pos:3
|Note|Dur:8th|Pos:-1
|Note|Dur:4th|Pos:-1
!NoteWorthyComposerClip-End
This is very odd. I've pasted this clip about five times. The source is not beamed, but whenever I post the clip and then download it, it is beamed. If I select the clip and copy and paste it into a blank score, it is not beamed. Huh?
  • Last Edit: 2012-01-18 04:21 am by fathafluff

  • Haymo
  • Virtuoso
Re: Automatic Beam Question
Reply #1
I also use NWC 2.5.2, and whichever way I get the clip into NWC, automatic beam does not beam the two sixteenth notes at the open master repeat.

Looks like a minor bug to me.

Re: Automatic Beam Question
Reply #2
I use version 2.5. The autoamtic beam seems to work perfectly.
Always look on the bright side of life!

Re: Automatic Beam Question
Reply #3
...whenever I post the clip and then download it, it is beamed. If I select the clip and copy and paste it into a blank score, it is not beamed. Huh?
Clarifying: The second part refers to beaming when a clip is opened. When I download and open the clip, the entire clip (except the two sixteenth notes) is beamed, even though the source was not beamed, but if I paste the clip, nothing is beamed. I.e. "It," in the second part, refers to the entire clip, not the sixteenth notes.

Re: Automatic Beam Question
Reply #4
When you select Automatic Beam, the two sixteenths at the start of the second strain do not beam. Is that because it is not a full measure?
In 6/8, two sixteenths are not a full pulse.
For your example:
  • Run the Automatic Beam Command
  • Change the TimeSig from 6/8 to 1/8 (or 3/8, but not 9/8 or 12/8)
  • Run the Automatic Beam Command
  • Change the TimeSig back to 6/8

Your clip is unbeamed when I put into NWC via the normal methods that I know of.
Registered user since 1996

Re: Automatic Beam Question
Reply #5
Normally, a pickup measure of simple meter is at least one beat; a pickup measure of compound meter is at least one pulse (3 beats). NWC's Automatic Beam Command detects compound meter (this cannot be turned off) and will not beam anything in pickup measures that are shorter than normal. This seems logical to me.
NWC's definition of compound meter is a bit non-standard. For example, NWC considers 15/8 compound. Many authorities would consider 15/8 to be irregular.

Quote from: An internet search of this may be helpful:
simple compound beat pulse
Registered user since 1996