Skip to main content

Topic: Triplet notation appearing in wrong place (Read 9616 times) previous topic - next topic

Triplet notation appearing in wrong place
I tried to triplet three quarter notes but the triplet (bar with the number 3 in the middle) wound up UNDER the staff instead of above the notes.  Note stems are all pointing down.

Re: Triplet notation appearing in wrong place
Reply #1
G'day Marty,
just had a look through my "Alfred's".  While the tuplet section is too long to reproduce here, essentially it says that normal or preferred placement of the tuplet bracket and numeral is on the stem side of the note.

However, it also makes allowance for the bracket and number to be on the head side if there is a need for it.

So, my interpretation is, that while your triplet mark is not where you'd prefer, it is actually correctly placed.  Nevertheless, it would be good if we had the option, all same as ties and slurs, or better still, a tick box like atriculations.  Along with tuplets other than triplets.

Perhaps a visit to the wish list?
I plays 'Bones, crumpets, coronets, floosgals 'n youfonymums - gonna lern tubies next

Re: Triplet notation appearing in wrong place
Reply #2
You can change the position of the duplet bracket by using a hidden staff with stems in the opposite direction as in this Duke Ellington "nested" triplet example that David Palmquist was working on a short time ago. If you view it in print preview you will have a clearer view.

Re: Triplet notation appearing in wrong place
Reply #3
G'day Fitz,
actually, that triplet is on the head end 'cos the leading rest has a stem direction of "down".

To confirm, unlayer your snippet, highlight the rest and press <shift-up> - see the triplet move?  Now <shift-down> and it goes back down.  <Shift-Down> again and that removes the explicit stem direction and it will stay down...

I plays 'Bones, crumpets, coronets, floosgals 'n youfonymums - gonna lern tubies next

Re: Triplet notation appearing in wrong place
Reply #4
As Lawrie says, the stem direction of the rest is controlling.
In NWC2, you can do this:
Code: [Select · Download]
!NoteWorthyComposerClip(2.0,Single)
|Note|Dur:4th,Triplet=First|Pos:1
|Note|Dur:4th,Triplet|Pos:2
|Note|Dur:4th,Triplet=End|Pos:3
|RestChord|Dur:4th,Triplet=First|Opts:Stem=Up,ArticulationsOnStem,VertOffset=16|Dur2:4th|Pos2:1
|Text|Text:"g"|Font:User1|Pos:15|Justify:Right|Color:2
|Note|Dur:4th,Triplet|Pos:2|Opts:Stem=Down
|Note|Dur:4th,Triplet=End|Pos:3|Opts:Stem=Down
|Note|Dur:4th,Triplet=First|Pos:-1
|Note|Dur:4th,Triplet|Pos:-2
|Note|Dur:4th,Triplet=End|Pos:-3
|RestChord|Dur:4th,Triplet=First|Opts:Stem=Down,ArticulationsOnStem,VertOffset=-6|Dur2:4th|Pos2:-1
|Text|Text:"g"|Font:User1|Pos:-13|Justify:Right|Color:2
|Note|Dur:4th,Triplet|Pos:-2
|Note|Dur:4th,Triplet=End|Pos:-3
!NoteWorthyComposerClip-End
Set Highlight 2 to "white" and Font:User 1 to Webdings, sized to about 125% of the System Font.
You may have to experiment with the Vertical Offset of the rests, which (unfortunately) must be done before you make it a RestChord.

A similar method should also work in NWC 1.75b
Registered user since 1996

Re: Triplet notation appearing in wrong place
Reply #5
Nice one Rick!
I plays 'Bones, crumpets, coronets, floosgals 'n youfonymums - gonna lern tubies next

Re: Triplet notation appearing in wrong place
Reply #6
How about this? You don't have to see the rests but I haven't figured out how to beam the eighth and sixteenths yet. Maybe using stems w/o heads? It's too late to bother with it now.

Re: Triplet notation appearing in wrong place
Reply #7
How about this? ...
It won't work with NWC 1.75b
This (NWC2 only) variation is a bit cleaner. 
[glow=red,2,300]Layer:[/glow]
Code: [Select · Download]
]!NoteWorthyComposerClip(2.0,Single)
|Note|Dur:4th,Triplet=First|Pos:-1z|Opts:Stem=Down,StemLength=0
|Note|Dur:4th,Triplet|Pos:-2|Opts:Stem=Up
|Note|Dur:4th,Triplet=End|Pos:-3|Opts:Stem=Up
|Note|Dur:4th,Triplet=First|Pos:1z|Opts:Stem=Up,StemLength=0
|Note|Dur:4th,Triplet|Pos:2|Opts:Stem=Down
|Note|Dur:4th,Triplet=End|Pos:3|Opts:Stem=Down
|Bar
|Note|Dur:4th,Triplet=First|Pos:-1z|Opts:Stem=Down,StemLength=1|Color:2
|Note|Dur:4th,Triplet|Pos:-2|Opts:Stem=Up
|Note|Dur:4th,Triplet=End|Pos:-3|Opts:Stem=Up
|Note|Dur:4th,Triplet=First|Pos:1z|Opts:Stem=Up,StemLength=1|Color:2
|Note|Dur:4th,Triplet|Pos:2|Opts:Stem=Down
|Note|Dur:4th,Triplet=End|Pos:3|Opts:Stem=Down
|Bar|SysBreak:Y
!NoteWorthyComposerClip-End
[glow=red,2,300]With:[/glow]
Code: [Select · Download]
!NoteWorthyComposerClip(2.0,Single)
|Note|Dur:4th|Pos:-1|Opts:Stem=Up,Muted
|Note|Dur:4th|Pos:-3z|Opts:Stem=Up,StemLength=1,Muted|Visibility:Never
|Note|Dur:4th|Pos:1|Opts:Stem=Down,Muted
|Note|Dur:4th|Pos:-3z|Opts:Stem=Up,StemLength=1,Muted|Visibility:Never
|Bar
|Note|Dur:4th|Pos:-1|Opts:Stem=Up,Muted
|Note|Dur:4th|Pos:-3z|Opts:Stem=Up,StemLength=1,Muted|Color:2
|Note|Dur:4th|Pos:1|Opts:Stem=Down,Muted
|Note|Dur:4th|Pos:-3z|Opts:Stem=Up,StemLength=1,Muted|Color:2
|Bar
!NoteWorthyComposerClip-End
The method in bar 2 requires Highlight 2 set to "white"
A problem arises if the line needs to be expanded for justification.
IOW, it looks a lot better in Print Preview if you uncheck Force System Break on the last bar.

IMO, NWC2 should not add justification space:
  • around notes whose visibility is set to never
  • before the first note in a bar
  • before the first note in a staff
  • after the last note in a bar
Registered user since 1996

Re: Triplet notation appearing in wrong place
Reply #8
Thank you one and all.  I thought that stem down would place the triple notation above, but evidently the opposite is true.  I changed the stem direction and everything is now fine.  I agree that an option should be given, and I will make that suggestion.

Martyd

Re: Triplet notation appearing in wrong place
Reply #9
Rick,
Your method like mine, only works for quarter notes or notes with no flags - I think. I am not sure I understand the whole white out thing. Can you remove the flags from stems of the eighth notes? If you use quarter note stems, the lateral distance between notes becomes a problem and as of now, there are no negetave values for note spacing so that you can only create more space, not less. It would be a lot easier if they just gave us the option to have the bracket above or below.

Re: Triplet notation appearing in wrong place
Reply #10
... I am not sure I understand the whole white out thing. ...
Tools->Options...->Colors
Click on one of: Highlight 1 - Highlight 7
Change...
Set: Red:, Green:, and Blue: to 255
Click on OK

Any object you set to this color via: Properties...->Visibility->Item color will be rendered as "white", overwriting anything that was rendered before it. The "g" character in the Webdings font is a nice big block that will "whiteout" a lot.

As to your flag problem, post a clip and I'll see if I can visually flip the bracket.
Registered user since 1996