Skip to main content
Topic: Import troubles (Read 108 times) previous topic - next topic

Import troubles

I tried to import a MIDI file putting all the channels in a single staff.
Of course I unchecked the relevant option and... one staff per channel, no matter.

To have all in a single staff I had to save the MIDI file in format type 0. This way it works.
But I saw nowhere the indication of "not for MIDI type 1".
Did I miss it?

Re: Import troubles

Reply #1
As well as unchecking "Map each Midi Channel to a new staff"  Did you also change the max single chord size to say about 50 ?

R.
Rich.

Re: Import troubles

Reply #2
No, Rich, I didn't, but that's not my problem.
The problem is strictly connected with channels and tracks.
And, even using a MIDI file type 0, I get a "tempo" hidden staff too.

Re: Import troubles

Reply #3
I think I got it.

The import wizard says: "The options below control how each track will be mapped into staves".
Also "Separate MIDI channels", in Options->Import->Track splitting options (in the help it's called "Map each MIDI channel to new staff") makes it clear: different track, different staff.
But, unless you're dealing with a MIDI type 0 file, who has only one track, usually (always...) each track has only one channel.

I was hoping I can still manually force all che channels in a single staff by editing the "list of import instructions" in the import wizard but it's impossible.

It seems the only way is the one I did: convert the MIDI file to type 0 and then import it with "Map each Midi Channel to a new staff" unchecked.

Re: Import troubles

Reply #4
I usually just let the Import Wizard do its thing when importing MIDI because I don't know what the alternate approach would be.  Are there some "best practices" that I should think about next time?

Re: Import troubles

Reply #5
It all depends on what you're needing!  ;)
Usually, the default is quite ok.
I was dealing with an odd request.

"The art of being wise is the art of knowing what to overlook."
   William James