Skip to main content
Topic: instrument setting (Read 241 times) previous topic - next topic

instrument setting

I am creating a new music file.
When selecting a new instrument, it seems selected well, but the sound I hear when entering notes or listening to the song is another sound.
The problem occured at Staff-9. I want to hear Voice-Oohs, but I hear a percussion instrument (I think).
What did I set wrong in the program?

Best regards,
Marianne

Re: instrument setting

Reply #1
In MIDI, Channel 10 always is the percussion channel - it uses percussion sounds by default.
So, just select another channel in F2 (staff properties) --> Midi tab --> Channel (bottommost field).

Why does this happen? By default, NWC increments the channel number for each new staff, so your staves get channel numbers 1, 2, 3, ... For the first 9 staves (Staff, Staff-1, Staff-2, etc. up to Staff-8) , all is fine. But then - oh - comes the tenth staff (which is called Staff-9 - you can change these names, BTW! - and you should use names that are more musically inclined, e.g. S, A, T, B, Violins, etc.); and that staff gets MIDI channel 10, and there you are.

But, there is typically* no problem if multiple staves use the same MIDI channel, if the staves use the same instrument**. So, you can open F2->Midi immediately after adding a new staff (e.g. with Ctrl-A) and set its channel number e.g. to 1 for all vocals***, 2 for all strings, 3 for all piano staves, 4 for all organ staves, and so on. If you have more than 15 voices at the same time, then ... well, it gets complicated (you need "multiple virtual MIDI cables" then, says me). But even Mozarts later symphonies are below this threshold, methinks.

* Of course, there are more advanced setups, with different virtual instruments, where one needs different channel numbers. But as long as you do not want to know too much about virtual instruments or soundfonts, you dont need them, I'd say.

** I wrote nonsense before about using only one channel - sorry!

*** There is a problem if the same note is played on different staves with the same channel if the note lengths are different: Then the first ending of the same notes will truncate that note on that channel; if this happens, you ... well ... need different channels again for the staves. Back to square 1.

(This whole text got out of control. I wanted to give you a one-line answer. Then I made a mistake. And then I started explaining away. Sorry.)

Regards
H.M.

Re: instrument setting

Reply #2
If you have more than 15 voices, then ...
You forgot a detail: "If you have more than 15 voices (instruments) at the same time..."
You can use a single MIDI channel with as many instruments you wish, just only one at a time!

Re: instrument setting

Reply #3
Yep - thx - changed!

H.M.

Re: instrument setting

Reply #4
H.M.,
Quote
*** There is a problem if the same note is played on different staves with the same channel if the note lengths are different: Then the first ending of the same notes will truncate that note on that channel; if this happens, you ... well ... need different channels again for the staves.

Some virtual synthesizers like CoolsoftVirtualMIDISynth have an option to only release the oldest instance when a note off midi event comes in. In that case a note with N "note on commands" will be muted only after N "note off commands".

I think this is not the default behavior in CoolsoftVirtualMIDISynth, so you'll have to modify the properties (under options) to achieve this result. But that removes the obligation to use different channels.

Bart