Skip to main content

Topic: Move Staff (Read 527 times) previous topic - next topic

Move Staff
I'm unable to use the keyboard shortcut Ctrl +Shift +PgUp  and Ctrl +Shift +PgDown today to move staffs up or down. 

The dropdown menu choices Staff - Move staff...  ,Staff - Move Staff Up and Staff - Move Staff Down methods work but the shortcut keys don't. 

I thought it might be corrected by closing and reopening the program, but not so.  I haven't yet rebooted - I have a LOT of programs on the go, so I'd prefer to hold off on that for now.

Is anyone else experiencing problems with these hotkey combinations at the moment?

Re: Move Staff
Reply #1
Do you use page up/down from the numeric keyboard and if so, have you switched num lock on?
Rich.

  • Bart
  • NWC2 User
Re: Move Staff
Reply #2
David,

I experience the same issue.

My Windows version is : Windows 10 Home 1903
My NWC version is : 2.8 Beta 1

I also use a simple, old text editor (Crimson Editor), and I noticed to my surprise that, when trying to select several lines with CTRL+SHIFT+PAGEDOWN nothing is selected anymore. I was not sure that it worked before, but it is something that I do in an automatic mode, so it must have been possible before.

I think we must blame MicroSoft that now blocks the CTRL+SHIFT+PAGE XXX key combination.

Bart

  • Bart
  • NWC2 User
Re: Move Staff
Reply #3
David,

Are you - like me - using Opera as browser?
I think I have unfairly blamed MicroSoft.
I found this web page (https://www.askvg.com/opera-bug-fix-ctrlshifthome-and-ctrlshiftend-hotkeys-stopped-working-in-text-editors/) and when I close my Opera browser, ctrl+shift+page up/down are working again (in NWC). Probably these key combinations are trapped by Opera.

Bart

Re: Move Staff
Reply #4
It works fine on my Win10 laptop.

- The non-num.block PgDn/PgUp keys do what they should with Ctrl-Shift (and without).
- The num.block PgDn/PgUp keys (3 and 9) work only if NumLock is not engaged. Otherwise, Ctrl-Shift-Num3 and Ctrl-Shift-Num9 work like PgDn/PgUp, i.e., the selected staff changes.

// Edit: Ah, the Opera explanation is nice!

H.M.

Re: Move Staff
Reply #5
Richard asked
Quote
Do you use page up/down from the numeric keyboard and if so, have you switched num lock on?
I always use my extended keyboard's  stand-alone Insert, Home, Page Up, Delete, End and Page Down and arrow keys.
PgUp and PdDn are on the numeric keypad as Shift-9 and Shift-3, but unlike my laptop, there's no Fn key. Ctrl-Shift-9 and Ctrl-Shift-3 behave the same as Shift-9 and Shift-3, and won't move a staff.

Bart wrote
Quote
...My NWC version is : 2.8 Beta 1...I think we must blame MicroSoft that now blocks the CTRL+SHIFT+PAGE XXX key combination....
and
Quote
Are you - like me - using Opera as browser?
I think I have unfairly blamed MicroSoft.
I found this web page (https://www.askvg.com/opera-bug-fix-ctrlshifthome-and-ctrlshiftend-hotkeys-stopped-working-in-text-editors/) and when I close my Opera browser, ctrl+shift+page up/down are working again (in NWC). Probably these key combinations are trapped by Opera
Yes, I use Opera.  It's open with multiple tabs almost all the time because I have project on the go that uses a webpage that takes a long time to open.  I've disabled the extension, but it hasn't done any good.  I'll try closing Opera after I finish this message and see what happens... Thanks for digging into this.

Re: Move Staff
Reply #6
Closing Opera did the trick.  When I reopened Opera the problem arose again, but I was able to disable the extension in the new Opera session and now the NWC shortcut works again.

Hopefully it will continue working without having to apply the fix again. 

Thank you very much to everyone who replied, and to Bart for finding the solution.