Skip to main content

Topic: Midi import bugs (Read 901 times) previous topic - next topic

Midi import bugs
It seems that, no matter if "insert instrument change" is checked or not, when opening a midi file without using the wizard the instrument changes are not imported.
Also the note resolution and rest resolution seem ignored. (This explains why I never had any effect fiddling with those parameters!)

Using the import wizard with the same options does get the "instrument change", but the imported score rhithm is... completely wrong.

Just to be clear, this is without wizard (correct):
Code: (nwc) [Select · Download]
!NoteWorthyComposerClip(2.75,Single)
|Clef|Type:Bass
|Key|Signature:C|Tonic:C
|Instrument|Patch:24|Trans:0|DynVel:10,30,45,60,75,92,108,127|Pos:8|Wide:Y
|TimeSig|Signature:4/4
|Rest|Dur:Whole
|Bar
|Chord|Dur:Whole|Pos:3,5,7
|Bar
|Chord|Dur:8th,Dotted|Pos:3^,5^,7^|Opts:Stem=Down,Beam=First
|Chord|Dur:64th|Pos:3,5,7|Opts:Stem=Down,Beam
|Chord|Dur:32nd,Dotted|Pos:3^,5^,7^|Opts:Stem=Down,Beam=End
|Chord|Dur:Half,Dotted|Pos:3,5,7|Opts:Stem=Down
|Bar
|Chord|Dur:8th,Dotted|Pos:3^,5^,7^|Opts:Stem=Down,Beam=First
|Chord|Dur:64th|Pos:3,5,7|Opts:Stem=Down,Beam
|Chord|Dur:32nd,Dotted|Pos:3^,5^,7^|Opts:Stem=Down,Beam=End
|Chord|Dur:Half,Dotted|Pos:3,5,7|Opts:Stem=Down
|Bar
!NoteWorthyComposerClip-End

With the wizard (options unchanged):
Code: (nwc) [Select · Download]
!NoteWorthyComposerClip(2.75,Single)
|Clef|Type:Bass
|Key|Signature:C|Tonic:C
|Instrument|Patch:24|Trans:0|DynVel:10,30,45,60,75,92,108,127|Pos:8|Wide:Y
|TimeSig|Signature:4/4
|Rest|Dur:Whole
|Bar
|Chord|Dur:Whole|Pos:3,5,7
|Bar
|Chord|Dur:8th,Dotted|Pos:3^,5^,7^|Opts:Stem=Down,Beam=First
|Chord|Dur:64th|Pos:3,5,7|Opts:Stem=Down,Beam
|Chord|Dur:32nd,Dotted|Pos:3^,5^,7^|Opts:Stem=Down,Beam=End
|Chord|Dur:Half,Dotted|Pos:3,5,7|Opts:Stem=Down
|Bar
|Chord|Dur:8th,Dotted|Pos:3^,5^,7^|Opts:Stem=Down,Beam=First
|Chord|Dur:64th|Pos:3,5,7|Opts:Stem=Down,Beam
|Chord|Dur:32nd,Dotted|Pos:3^,5^,7^|Opts:Stem=Down,Beam=End
|Chord|Dur:Half,Dotted|Pos:3,5,7|Opts:Stem=Down
|Bar
!NoteWorthyComposerClip-End

  • Bart
  • NWC2 User
Re: Midi import bugs
Reply #1
Flurmy,

Both captures seem identical to me. 
But, how can I get a midi -file into NWC without using the wizard?
The wizard starts as soon as I try to "open" or "import" a midi file.

Bart

Re: Midi import bugs
Reply #2
Tools -> Options -> File -> Use import wizard on open

  • Bart
  • NWC2 User
Re: Midi import bugs
Reply #3
Thank you, Flurmy. I see.  ;)
This option is indeed checkboxed in my version.

Bart

Re: Midi import bugs
Reply #4
Tools -> Options -> File -> Use import wizard on open
Perhaps the help entry should be changed to explain what this options actually does  :))
Registered user since 1996