Skip to main content

Topic: 2.5.5. Hangs When Accessing "New..." (Read 5444 times) previous topic - next topic

2.5.5. Hangs When Accessing "New..."
I have been using the latest upgrade for a week without problems but today the program crashed when I clicked "New" in the File Menu. When attempting to close the program I received the Windows (XP PRO) "Program does not respond message". Restarting did not help.

After I reinstalled both 2.1 and the 2.5.1 upgrade I did not have a problem starting a new file; but then after I installed the 2.5.5  upgrade the same problem reoccured.

Here is the Windows log :
"Hanging application NWC2.exe, version 2.5.5.0, hang module hungapp, version 0.0.0.0, hang address 0x00000000."

Is it a bug in this upgrade or could it be a local problem?

JZ


Re: 2.5.5. Hangs When Accessing "New..."
Reply #1
I am using XPPro. NWC 2.5.5 does not hang when I access my templates using File->New
Perhaps you should try deleting your existing templates and re-installing.
IRRC, NWC does not update templates if they already exist.
Registered user since 1996

Re: 2.5.5. Hangs When Accessing "New..."
Reply #2
Thanks Rick,

Somehow hundreds of nwc files ended up in the Template folder. I removed them then installed 2.5.5.  and now can use  "New" without a problem. (Don't know how those files got in there other than through inadvertant key strokes.)

JZ

Re: 2.5.5. Hangs When Accessing "New..."
Reply #3
I also tried openeing a "New File" using File->New. I am afraid that this hangs NWC:  at first nothing seems to happen but when I try to click on some other command, the window containing nwc says "program not responding" and I have to force-close the program.  The computer does not hang however.  It appears that I have the same problem as jzeeman.

On the other hand, I can easily open the templates themselves using File->Open and navigating to the templates subfolder.  This means, IMO, that the problem does not lie with the files themselves.  I only have some 25 files, divided into 3 folders under the templates folder.

(I am using XPPro and NWC 2.5.5).  

Re: 2.5.5. Hangs When Accessing "New..."
Reply #4
I, too, had the problem of 2.5.5 hanging on the "New File" command, whether accessed from the drop down menu or the tool icon.  Today I tried moving all my templates to a different folder and moving them back into the templates folder a few at a time.  I found that the culprit was a "bak" file to one of my templates that I assume NWC made when I changed the template back in 2011.  I'd never had any problem with it until this version.  However, with the offending file stashed safely away in another folder, everything's back to normal, even with some nwc files in the templates folder that really don't belong there.

Ivan

Re: 2.5.5. Hangs When Accessing "New..."
Reply #5
Thanks Ivan/bradley.

That cured my problem too.

But why on earth should that happen at all in the first place ?

By the way, I was having problems with MusicXML to NWC converter (v. 1.12 by Niversoft):  the conversion would stop when importing into NWC and lock both mxml2nwc and nwc.  I had to re-install NWC version 2.0 side by side with the current NCW version 2.5.5 to get around the problem.  I used to convert to version 2.0 and then open and save in version 2.5.5.  However this .bak issue in the templates folder cured this poblem as well and now I can import directly into version 2.5.5.

Thanks.

Re: 2.5.5. Hangs When Accessing "New..."
Reply #6
I too have all of a sudden have 2.5.5 hang and "not respond" when I click on "New".  I only have one template that I've made that I've used probably 10 times with no problem until today.  I deleted the back-up to this template and the "New" command now works.  There certainly seems to be bug somewhere that it is happening to more than one person.