NoteWorthy Composer Forum

Forums => General Discussion => Topic started by: katmay47 on 2019-11-14 04:53 pm

Title: Where is "In Port" on Options/Record tab?
Post by: katmay47 on 2019-11-14 04:53 pm
Hi.  I'm a new NWC user, trying to get my Midi keyboard to work with NWC.  I know NWC recognizes my sound device (Scarlett Focusrite USB) because I keep getting alerts that it failed in the In Port.  The FAQs mention that I should choose an In Port under Options on the Record Tab, but there is no option to choose an In or Out port on the Record tab.  Screen shot attached.  Any suggestions?  I sure would appreciate the help.
Thank you!
Katherine
Title: Re: Where is "In Port" on Options/Record tab?
Post by: William Ashworth on 2019-11-14 06:25 pm
There's a disjunct between the labels as stated in the FAQs and the labels on the "Record" tab. The in port is chosen under "Echo Input to Play Device"; the out port is chosen under "Echo to MIDI Channel".
Title: Re: Where is "In Port" on Options/Record tab?
Post by: Bart on 2019-11-14 06:38 pm
Katherine,

There is a "keyboard" icon in the "file bar" and when you hover over it, it will display: MIDI Input Active.
If you "enable" that button, your midi notes should be captured in NWC.

I don't know if it is really useful, since all notes are quarter notes when I try it. Maybe I miss something, but at least the notes come through.

Bart
Title: Re: Where is "In Port" on Options/Record tab?
Post by: katmay47 on 2019-11-14 07:25 pm
Thank you both!  Bart, I found the keyboard icon, and clicking for Midi Input Active brings the message that the device fails to open, so I should go to the Recording Tab.
And William, I see "Echo Input to Play Device" on the Recording tab, but there isn't an option to choose the Focusrite -- only my computer's play device.  I added the Focusrite in the Control Panel Sounds tab, but it still doesn't show up as an option.  Ack.  Any more suggestions?
Thanks again, guys, for your time!
Katherine
Title: Re: Where is "In Port" on Options/Record tab?
Post by: Bart on 2019-11-15 02:39 pm
Katherine,

Quote
clicking for Midi Input Active brings the message that the device fails to open

That's not good. I am not sure, but I suppose that you shouldn't search for the problem and a solution in NWC in this situation.

It seems that your driver on Windows doesn't recognize your external keyboard correctly - at least not your IN-port.

Is the OUT-port working correctly?  With older keyboards you always had two different MIDI ports for IN and OUT - And you had to connect them in a - for me - very illogical way. That's what I remember.

I would suggest you first to try that your IN and OUT-ports are working correctly with other (windows) software, but I don't know with which software you could do that easily.

MIDI-OX is an old software that I know it did the job, but I don't know if it still can be found.

I know this is not a good answer to your question, but that's all I have.
Sorry.

Bart
Title: Re: Where is "In Port" on Options/Record tab?
Post by: katmay47 on 2019-11-15 05:51 pm
Hi, Bart,
No apology needed -- I appreciate your time and effort, and the software suggestion.  I'll try to find it.
I can get the Scarlett to work with Audacity, just not with NWC, so it sounds like it's a failure of NWC to recognize other input devices in addition to the computer's program...
Thanks for your suggestions -- I'll keep trying!  Best of luck to you.
Katherine
Title: Re: Where is "In Port" on Options/Record tab?
Post by: Flurmy on 2019-11-15 08:32 pm
Audacity? Does Audacity manages MIDI?
Well, it's a long time since I used it...
Title: Re: Where is "In Port" on Options/Record tab?
Post by: katmay47 on 2019-11-16 04:30 pm
Not sure it manages MIDI, but I did get my MIDI keyboard to record in Audacity through the Scarlett.
So many options out there!
Title: Re: Where is "In Port" on Options/Record tab?
Post by: Bart on 2019-11-17 05:27 pm
Katherine,

I don't know Scarlett Focusrite but I have been looking around for some information about it.
In the configuration tutorials that I have found, everyone always explains how to setup the sound for Scarlett Focusrite but no-one is explaining the MIDI setup. It looks as if Focusrite is not designed to transfer MIDI signals to a PC.

If I also looked again closely at your device settings in the NWC Record tab, it says : Focusrite USB Audio. I suppose this isn't a MIDI device, but an AUDIO device. An AUDIO device cannot talk with NWC. Recording in NWC must be done in MIDI-language, so unless your Focusrite also has an option to behave as a MIDI device, you probably won't be able to use it with NWC.
The message that the device failed to open is logical if you try to connect an AUDIO device when a MIDI device is expected.

As you told us, I saw that recent versions of AUDACITY now has MIDI capabilities, which are handled in the time tracks. I didn't find the possibility to capture MIDI signals in such a track.
AUDACITY was always good in handling (recording, manipulating, ...) AUDIO. So, I think you may have recorded audio in AUDACITY. But, as said, audio cannot be used in NWC.

You can of course always try to connect your keyboard directly to your PC - without Focusrite. Then you can "talk" in MIDI and that's what NWC understands. When you connect your keyboard directly to your PC, you should find a new MIDI-device in your devices list, for which you may have to install a new driver and which doesn't appear as an audio device.

Bart


Title: Re: Where is "In Port" on Options/Record tab?
Post by: katmay47 on 2019-11-19 01:09 am
Thank you for your thoughtful reply, Bart!  I hadn't thought of connecting my keyboard directly to the computer -- since NWC requires a sound card, I thought I needed something between the keyboard and computer, but I imagine the computer has a sound card.  Dar.  Thanks for the suggestion!
The guys at the music store told me that the Scarlett would function as a sound card -- a USB interface -- but maybe it IS just an audio device.  I'll try hooking it up directly.  Thanks again for your time!
Title: Re: Where is "In Port" on Options/Record tab?
Post by: Rick G. on 2019-11-19 02:44 am
NWC requires a sound card
No, it does not. If you want to connect a MIDI input device (e.g., a Keyboard) that uses a pair of 5-pin plugs, you will need an adapter. Google 'MIDI to usb' for some options. Some of the newer MIDI devices output directly to usb.
Title: Re: Where is "In Port" on Options/Record tab?
Post by: katmay47 on 2019-11-20 01:37 am
Ah, that makes sense!  My keyboard does have the two 5-prong plugs where it says Midi In and Midi Out.  Thank you, Bart!  Good thing I bought the Scarlett for something else...

Do you know then what I would choose as the Input Device in the Record tab if I choose the Midi-to-USB connector?

This is really helpful -- thanks!

Katherine
Title: Re: Where is "In Port" on Options/Record tab?
Post by: Bart on 2019-11-24 06:19 pm
Katherine,

It is hard to tell how your device is named on your computer.
I only have one possible midi-in device and it is called USB2.0-MIDI.

Bart
Title: Re: Where is "In Port" on Options/Record tab?
Post by: katmay47 on 2019-11-25 04:22 pm
Is that a port on your computer, or a software program, or something else?  I'm not familiar.
Title: Re: Where is "In Port" on Options/Record tab?
Post by: Bart on 2019-11-26 06:53 pm
Katherine,

I find an entry for this device in my Windows 10 under SETTINGS - DEVICES - BLUETOOTH & OTHER DEVICES.
So, this should be a device with a specific device driver. I don't remember if I have installed a driver for my "midi-usb cable" manually or that Windows automatically recognized my "cable" and installed a suitable driver.

What options do you have in the NWC record screen?
Be aware that sometimes a device is only found when active at the moment that you start a program. Especially my midi device can be hidden if powered on after a music program is already running.

Bart
Title: Re: Where is "In Port" on Options/Record tab?
Post by: Rick G. on 2019-11-26 08:43 pm
The FAQs mention that I should choose an In Port under Options on the Record Tab, but there is no option to choose an In or Out port on the Record tab.
There is an option to choose an In Port. If you have more than one recognized MIDI In port, the 'Input Device:'  field will drop down and let you select the one you want to use. If you have no devices, the drop down is blank. If you only have one Input Device, it will be selected and cannot be deselected. The option is there, it is just of no real consequence unless you have multiple devices.
Title: Re: Where is "In Port" on Options/Record tab?
Post by: katmay47 on 2019-11-28 04:08 pm
Thanks for your answer, Rick.  I guess the problem is that the field is blank.  I typed in the device I want to use, a Scarlett Focusrite audio interface, but NWC doesn't want to recognize it.  Can you suggest other possible input devices?  Software?  Kind of stumped here.
Thanks for your time!
Katherine
Title: Re: Where is "In Port" on Options/Record tab?
Post by: katmay47 on 2019-11-28 04:31 pm
Bart, my computer is quite old -- 10 years now -- and the only devices it shows are mouse and printer.  And the Input Device option in the Record tab is blank, so there's nothing set up.  I downloaded the MidiOx program, but it doesn't show up either.   Perhaps my computer is just too old!  I'll try a MIDI/USB cable next, and see if it'll go direct.  Thanks for your time!
Title: Re: Where is "In Port" on Options/Record tab?
Post by: Rick G. on 2019-11-28 04:49 pm
Perhaps my computer is just too old!  I'll try a MIDI/USB cable next, and see if it'll go direct. 
For MIDI, old is good. A MIDI/USB cable should work for you. Alternatively, a cheap, dedicated USB, two octave or so keyboard is possibly the simplest option.
Title: Re: Where is "In Port" on Options/Record tab?
Post by: hmmueller on 2019-11-28 06:10 pm
...a cheap, dedicated USB, two octave or so keyboard
- shameless plug: I have the AKAI LPK-25 (https://www.akaipro.com/lpk25) and am quite happy with it (using the left hand for the AKAI and the right for the laptop/computer keyboard, even when travelling with the S-Bahn).

H.M.