NoteWorthy Composer Forum

Forums => Tips & Tricks => Object Plugins => Topic started by: Mike Shawaluk on 2015-08-06 11:30 pm

Title: Glissando.ms (2.11)
Post by: Mike Shawaluk on 2015-08-06 11:30 pm
This will draw a glissando line between two notes, with optional text above the line. If either of the notes is a chord, the bottom notehead of that chord will be the starting or ending point of the line. Effective with NWC version 2.75a, the object can optionally be configured for playback.

Paste the following snippet into NWC 2.75a, then go to Tools > Manage Objects to install the object.
Code: (nwc) [Select · Download]
!NoteWorthyComposerClip(2.75,Single)
|Note|Dur:Whole|Pos:-6
|User|Glissando.ms|Pos:0
|Note|Dur:Whole|Pos:8
|Note|Dur:Whole|Pos:8
|User|Glissando.ms|Pos:0|Pen:wavy
|Note|Dur:Whole|Pos:-6
!NoteWorthyComposerClip-End

For details on the object's parameters, refer to the context-sensitive help on object's properties page.
Title: Re: Glissando.ms (version 0.9)
Post by: Lawrie Pardy on 2015-08-07 12:16 am
Thanks buddy :)
Title: Re: Glissando.ms (1.2)
Post by: Mike Shawaluk on 2015-10-11 12:20 pm
The Glissando.ms object has been updated, with the following changes:
Title: Evanescent glissando
Post by: Flurmy on 2015-10-11 09:21 pm
In my score the glissando is not visible in edit mode nor in print preview mode but only in viewer mode.
I extracted this small piece and the glissando is never visible.

Code: (nwc) [Select · Download]
!NoteWorthyComposerClip(2.75,Single)
|Clef|Type:Treble
|Key|Signature:C|Tonic:C
|TimeSig|Signature:Common
|Dynamic|Style:f|Pos:-8|Visibility:Never
|User|TremoloSingle.ms|Pos:0|Beams:2|Play:N
|Chord|Dur:Half|Pos:-3,#-2,0,2|Opts:Stem=Down,StemLength=8,Muted
|User|TremoloSingle.ms|Pos:0|Beams:2|Play:N
|Chord|Dur:Half|Pos:3,5,7,10|Opts:Stem=Up,StemLength=8,Muted
|User|Glissando.ms|Pos:10|Scale:65
|Bar
|Rest|Dur:Whole|Visibility:Never
|Bar
!NoteWorthyComposerClip-End
Title: Re: Glissando.ms (1.2)
Post by: Richard Woodroffe on 2015-10-11 09:28 pm
The Glissando object should be between two notes/chords. Not between a note/chord and a rest.

If you need it at the end like that to indicate a sweep down, then use a  muted grace whole note with a blank head

Title: Re: Glissando.ms (1.2)
Post by: Flurmy on 2015-10-11 09:34 pm
Right!
Since my score has no target note for glissato I overlooked this detail.
thank you.
Title: Re: Glissando.ms (1.3)
Post by: Mike Shawaluk on 2015-11-09 01:33 pm
The Glissando.ms object has been updated, with the following changes:


Please refer to the parent post for additional information.
Title: A key point...
Post by: Flurmy on 2017-04-22 08:08 pm
The glissando ignores the key change:
Code: (nwc) [Select · Download]
!NoteWorthyComposerClip(2.751,Single)
|Clef|Type:Treble
|Key|Signature:C|Tonic:C
|TimeSig|Signature:4/4
|Tempo|Tempo:168|Pos:10|Visibility:Never
|Chord|Dur:4th|Pos:-3,-1,2,3
|Chord|Dur:4th|Pos:-8,-3,-1,#1,3
|Chord|Dur:8th|Pos:n-6,-3,-1,#1,3|Opts:Stem=Up,Beam=First
|Chord|Dur:8th|Pos:#-6,-3,-1,1,3|Opts:Stem=Up,Beam=End
|Rest|Dur:8th
|Chord|Dur:8th|Pos:-5^,-3^,-1^,1^,3^
|Bar
|Chord|Dur:Half|Pos:-5,-3,-1,1,3|Opts:Stem=Up,Muted
|User|Glissando.ms|Pos:1|Playback:WhiteKeys|EndOffsetY:-10|Pen:wavy
|Clef|Type:Bass|Visibility:Never
|Note|Dur:8th,Grace|Pos:-2|Opts:Stem=Up,Muted|Visibility:Never
|Rest|Dur:Half
|Clef|Type:Treble|Visibility:Never
|Bar
!NoteWorthyComposerClip-End
Of course I can olways write this way, cluttering up a bit the score in edit mode:
Code: (nwc) [Select · Download]
!NoteWorthyComposerClip(2.751,Single)
|Clef|Type:Treble
|Key|Signature:C|Tonic:C
|TimeSig|Signature:4/4
|Tempo|Tempo:168|Pos:10|Visibility:Never
|Chord|Dur:4th|Pos:-3,-1,2,3
|Chord|Dur:4th|Pos:-8,-3,-1,#1,3
|Chord|Dur:8th|Pos:n-6,-3,-1,#1,3|Opts:Stem=Up,Beam=First
|Chord|Dur:8th|Pos:#-6,-3,-1,1,3|Opts:Stem=Up,Beam=End
|Rest|Dur:8th
|Chord|Dur:8th|Pos:-5^,-3^,-1^,1^,3^
|Bar
|Chord|Dur:Half|Pos:-5,-3,-1,1,3|Opts:Stem=Up,Muted
|User|Glissando.ms|Pos:1|Playback:WhiteKeys|Pen:wavy|EndOffsetY:8
|Note|Dur:8th,Grace|Pos:-21|Opts:Stem=Up,Muted|Visibility:Never
|Rest|Dur:Half
|Bar
!NoteWorthyComposerClip-End
I think it's worth to know
Title: Re: Glissando.ms (1.3)
Post by: Flurmy on 2017-04-22 08:29 pm
There is also a problem with the timing.
Code: (nwc) [Select · Download]
!NoteWorthyComposer(2.751)
|Editor|ActiveStaff:1|CaretIndex:1|CaretPos:-13
|SongInfo|Title:""|Author:"<Name>"|Lyricist:""|Copyright1:"Copyright © 2017 <Name>"|Copyright2:"All Rights Reserved"
|PgSetup|StaffSize:16|Zoom:4|TitlePage:Y|JustifyVertically:Y|PrintSystemSepMark:N|ExtendLastSystem:N|DurationPadding:Y|PageNumbers:0|StaffLabels:None|BarNumbers:None|StartingBar:1
|Font|Style:StaffItalic|Typeface:"Times New Roman"|Size:10|Bold:Y|Italic:Y|CharSet:0
|Font|Style:StaffBold|Typeface:"Times New Roman"|Size:8|Bold:Y|Italic:N|CharSet:0
|Font|Style:StaffLyric|Typeface:"Times New Roman"|Size:7.2|Bold:N|Italic:N|CharSet:0
|Font|Style:PageTitleText|Typeface:"Times New Roman"|Size:24|Bold:Y|Italic:N|CharSet:0
|Font|Style:PageText|Typeface:"Times New Roman"|Size:12|Bold:N|Italic:N|CharSet:0
|Font|Style:PageSmallText|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User1|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User2|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User3|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User4|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User5|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User6|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|PgMargins|Left:1.27|Top:1.27|Right:1.27|Bottom:1.27|Mirror:N
|AddStaff|Name:"Staff"|Group:"Standard"
|StaffProperties|EndingBar:Section Close|Visible:Y|BoundaryTop:12|BoundaryBottom:12|Lines:5|Color:Default
|StaffProperties|Muted:N|Volume:127|StereoPan:64|Device:0|Channel:1
|StaffInstrument|Name:"Trumpet"|Patch:56|Trans:0|DynVel:10,30,45,60,75,92,108,127
|Clef|Type:Treble
|Key|Signature:C|Tonic:C
|TimeSig|Signature:4/4
|Rest|Dur:4th
|Note|Dur:4th|Pos:#1
|Note|Dur:8th|Pos:1|Opts:Stem=Down,Beam=First
|Note|Dur:8th|Pos:1^|Opts:Stem=Down,Beam=End
|Note|Dur:8th|Pos:1|Opts:Stem=Down,Beam=First
|Note|Dur:8th|Pos:1^|Opts:Stem=Down,Beam=End
|Bar
|Note|Dur:Half|Pos:1|Opts:Muted
|User|Glissando.ms|Pos:1|Playback:Chromatic|Pen:wavy
|Note|Dur:8th,Grace|Pos:-7|Opts:Stem=Up,Muted|Visibility:Never
|Rest|Dur:Half
|Bar
!NoteWorthyComposer-End
If I don't mute the note before the glissato then it plays for all the glissando duration.
If I mute the note before the glissato then it plays for... ever.

And then, how the object knows when to start the glissato?
This sounds good but looks not so well:
Code: (nwc) [Select · Download]
!NoteWorthyComposerClip(2.751,Single)
|Clef|Type:Treble
|Key|Signature:C|Tonic:C
|TimeSig|Signature:4/4
|Rest|Dur:4th
|Note|Dur:4th|Pos:#1
|Note|Dur:8th|Pos:1|Opts:Stem=Down,Beam=First
|Note|Dur:8th|Pos:1^|Opts:Stem=Down,Beam=End
|Note|Dur:8th|Pos:1|Opts:Stem=Down,Beam=First
|Note|Dur:8th|Pos:1|Opts:Stem=Down,Beam=End
|Bar
|Note|Dur:Half|Pos:1|Opts:Muted
|User|Glissando.ms|Pos:1|Playback:Chromatic|Pen:wavy
|Note|Dur:8th,Grace|Pos:-7|Opts:Stem=Up,Muted|Visibility:Never
|Rest|Dur:Half
|Bar
!NoteWorthyComposerClip-End
Title: Re: Glissando.ms (1.3)
Post by: Mike Shawaluk on 2017-04-22 10:55 pm
The problem is the tie going into the glissando starting note. When there are two tied notes in NWC, the tie basically tells the first note to play only its "note on" and the second note to play only its  "note off", so they sound as a single note of the combined duration. Muting the second note will suppress its "note off", causing a hanging note. Removing the tie makes it sound better, since there is no longer a hanging note, and the glissando is able to play during the muted half note.

Following is my attempt at a "fix" of the score:
Code: (nwc) [Select · Download]
!NoteWorthyComposerClip(2.751,Single)
|Clef|Type:Treble
|Key|Signature:C|Tonic:C
|TimeSig|Signature:4/4
|Rest|Dur:4th
|Note|Dur:4th|Pos:#1
|Note|Dur:8th|Pos:1|Opts:Stem=Down,Beam=First
|Note|Dur:8th|Pos:1^|Opts:Stem=Down,Beam=End
|Note|Dur:8th|Pos:1|Opts:Stem=Down,Beam=First
|Note|Dur:8th|Pos:1^|Opts:Stem=Down,Beam=End
|Bar
|Note|Dur:8th,Grace|Pos:1|Visibility:Never
|Note|Dur:Half|Pos:1|Opts:Muted
|User|Glissando.ms|Pos:1|Playback:Chromatic|Pen:wavy
|Note|Dur:8th,Grace|Pos:-7|Opts:Stem=Up,Muted|Visibility:Never
|Rest|Dur:Half
|Bar
!NoteWorthyComposerClip-End
It sounds correct to me, and looks correct in view/print mode.
Title: Re: Glissando.ms (1.3)
Post by: Flurmy on 2017-04-23 07:50 am
Good idea!
Thanks, Mike.
Title: Re: Glissando.ms (1.2)
Post by: Mike Shawaluk on 2017-08-28 09:30 pm
The Glissando.ms object has been updated with version 2.75a, with the following changes:
Title: Re: Glissando.ms (2.11)
Post by: Flurmy on 2017-10-06 08:07 pm
There is something wrong in the "pitch bend" glissato:
Code: (nwc) [Select · Download]
!NoteWorthyComposer(2.751)
|Editor|ActiveStaff:1|CaretIndex:1|CaretPos:0
|SongInfo|Title:""|Author:"<Name>"|Lyricist:""|Copyright1:"Copyright © 2017 <Name>"|Copyright2:"All Rights Reserved"
|PgSetup|StaffSize:16|Zoom:4|TitlePage:Y|JustifyVertically:Y|PrintSystemSepMark:N|ExtendLastSystem:N|DurationPadding:Y|PageNumbers:0|StaffLabels:None|BarNumbers:None|StartingBar:1
|Font|Style:StaffItalic|Typeface:"Times New Roman"|Size:10|Bold:Y|Italic:Y|CharSet:0
|Font|Style:StaffBold|Typeface:"Times New Roman"|Size:8|Bold:Y|Italic:N|CharSet:0
|Font|Style:StaffLyric|Typeface:"Times New Roman"|Size:7.2|Bold:N|Italic:N|CharSet:0
|Font|Style:PageTitleText|Typeface:"Times New Roman"|Size:24|Bold:Y|Italic:N|CharSet:0
|Font|Style:PageText|Typeface:"Times New Roman"|Size:12|Bold:N|Italic:N|CharSet:0
|Font|Style:PageSmallText|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User1|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User2|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User3|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User4|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User5|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User6|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|PgMargins|Left:1.27|Top:1.27|Right:1.27|Bottom:1.27|Mirror:N
|AddStaff|Name:"Staff"|Group:"Standard"
|StaffProperties|EndingBar:Section Close|Visible:Y|BoundaryTop:12|BoundaryBottom:12|Lines:5|Color:Default
|StaffProperties|Muted:N|Volume:127|StereoPan:64|Device:0|Channel:1
|StaffInstrument|Name:"Brass Section"|Patch:61|Trans:0|BendRange:24|DynVel:10,30,45,60,75,92,108,127
|Clef|Type:Treble
|Key|Signature:C|Tonic:C
|Tempo|Tempo:168|Pos:10|Visibility:Never
|TimeSig|Signature:4/4
|Rest|Dur:8th
|Chord|Dur:4th,Accent|Pos:-1,6
|Chord|Dur:4th,Accent|Pos:1,8
|Chord|Dur:4th,Accent|Pos:#1,#8
|Chord|Dur:8th,Accent|Pos:2^,9^
|Bar
|Chord|Dur:4th|Pos:2,9|Opts:Muted
|User|Glissando.ms|Pos:0|Playback:PitchBend
|Note|Dur:8th,Grace|Pos:0|Opts:Stem=Up,StemLength=4.7,Muted|Visibility:Never
|Rest|Dur:Half,Dotted
!NoteWorthyComposer-End
Title: Re: Glissando.ms (2.11)
Post by: Mike Shawaluk on 2017-10-06 10:03 pm
If you unmute the starting note (the tied-in quarter note), it seems to play back as intended. (And yes, I know that the instructions say that both notes should be muted, but this might be an exception to that rule)
Title: Re: Glissando.ms (2.11)
Post by: Flurmy on 2017-10-07 07:50 am
Yes, much better, but not perfect.
I hear the pitch bend returning rapidly to the neutral position slightly before the playing ends.
It should be slightly after.  ;)
Title: Re: Glissando.ms (2.11)
Post by: Rick G. on 2017-10-07 05:41 pm
I hear the pitch bend returning rapidly to the neutral position slightly before the playing ends.
You shouldn't. This is the MIDI produced by Measure 2:
Code: (mtx) [Select · Download]
768 Pb ch=1 v=8192
770 Pb ch=1 v=8181
772 Pb ch=1 v=8170
774 Pb ch=1 v=8159
776 Pb ch=1 v=8148
778 Pb ch=1 v=8137
780 Pb ch=1 v=8126
782 Pb ch=1 v=8115
784 Pb ch=1 v=8104
786 Pb ch=1 v=8093
788 Pb ch=1 v=8083
790 Pb ch=1 v=8072
792 Pb ch=1 v=8061
794 Pb ch=1 v=8050
796 Pb ch=1 v=8039
798 Pb ch=1 v=8028
800 Pb ch=1 v=8017
802 Pb ch=1 v=8006
804 Pb ch=1 v=7995
806 Pb ch=1 v=7985
808 Pb ch=1 v=7974
810 Pb ch=1 v=7963
812 Pb ch=1 v=7952
814 Pb ch=1 v=7941
816 Pb ch=1 v=7930
818 Pb ch=1 v=7919
820 Pb ch=1 v=7908
822 Pb ch=1 v=7897
824 Pb ch=1 v=7887
826 Pb ch=1 v=7876
828 Pb ch=1 v=7865
830 Pb ch=1 v=7854
832 Pb ch=1 v=7843
834 Pb ch=1 v=7832
836 Pb ch=1 v=7821
838 Pb ch=1 v=7810
840 Pb ch=1 v=7799
842 Pb ch=1 v=7788
844 Pb ch=1 v=7778
846 Pb ch=1 v=7767
848 Pb ch=1 v=7756
850 Pb ch=1 v=7745
852 Pb ch=1 v=7734
854 Pb ch=1 v=7723
856 Pb ch=1 v=7712
858 Pb ch=1 v=7701
860 Pb ch=1 v=7690
862 Pb ch=1 v=7680
864 Pb ch=1 v=7669
866 Pb ch=1 v=7658
868 Pb ch=1 v=7647
870 Pb ch=1 v=7636
872 Pb ch=1 v=7625
874 Pb ch=1 v=7614
876 Pb ch=1 v=7603
878 Pb ch=1 v=7592
880 Pb ch=1 v=7582
882 Pb ch=1 v=7571
884 Pb ch=1 v=7560
886 Pb ch=1 v=7549
888 Pb ch=1 v=7538
890 Pb ch=1 v=7527
892 Pb ch=1 v=7516
894 Pb ch=1 v=7505
896 Pb ch=1 v=7494
898 Pb ch=1 v=7484
900 Pb ch=1 v=7473
902 Pb ch=1 v=7462
904 Pb ch=1 v=7451
906 Pb ch=1 v=7440
908 Pb ch=1 v=7429
910 Pb ch=1 v=7418
912 Pb ch=1 v=7407
914 Pb ch=1 v=7396
916 Pb ch=1 v=7385
918 Pb ch=1 v=7375
920 Pb ch=1 v=7364
922 Pb ch=1 v=7353
924 Pb ch=1 v=7342
926 Pb ch=1 v=7331
928 On ch=1 n=74 v=0
928 On ch=1 n=86 v=0
928 Pb ch=1 v=7320
930 Pb ch=1 v=7309
932 Pb ch=1 v=7298
934 Pb ch=1 v=7287
936 Pb ch=1 v=7277
938 Pb ch=1 v=7266
940 Pb ch=1 v=7255
942 Pb ch=1 v=7244
944 Pb ch=1 v=7233
946 Pb ch=1 v=7222
948 Pb ch=1 v=7211
950 Pb ch=1 v=7200
952 Pb ch=1 v=7189
954 Pb ch=1 v=7179
956 Pb ch=1 v=7168
960 Pb ch=1 v=8192
As you can see, the notes are turned off long before the Pb is reset.
Title: Re: Glissando.ms (2.11)
Post by: Flurmy on 2017-10-07 06:09 pm
Yes, the MIDI is correct.
It's playing inside NWC that sounds wrong.
Indeed the problem is my synth.
If I use an external keyboard or the (in)famous Microsoft GS wavetable there is no problem.
Sorry.
Title: Re: Glissando.ms (2.11)
Post by: Jorge D. Fuentes on 2018-02-03 02:40 am
Sorry for the thread necromancy.
I love this Glissando effect.  I'm using it to do some Flute glissandos and some String glissandos.
However, I'm trying to also use a Crescendo effect, effectively changing note-on velocity for the notes.
The Glissando notes, however, aren't following the Crescendo.  They are ignoring it and using the velocity (dynamic marking) that is before the < marking.
Can you make the Glissando notes adhere to Crescendos and Decrescendo/Graphic Crescendo and Decrescendo rules?
(I'm using the White Notes/Black Notes/Chromatic glissando, not the pitchbend one).
Title: Re: Glissando.ms (2.11)
Post by: Rick G. on 2018-02-03 02:55 am
The Glissando notes, however, aren't following the Crescendo.  They are ignoring it and using the velocity (dynamic marking) that is before the < marking.
Can you make the Glissando notes adhere to Crescendos and Decrescendo/Graphic Crescendo and Decrescendo rules?
You need to use volume, not note velocity.
Code: (nwc) [Select · Download]
!NoteWorthyComposerClip(2.751,Single)
|Clef|Type:Treble
|Key|Signature:C|Tonic:C
|TimeSig|Signature:4/4
|Rest|Dur:4th
|Dynamic|Style:f|Opts:Velocity=127,Volume=92|Pos:-8
|Note|Dur:4th|Pos:#1
|Note|Dur:8th|Pos:1|Opts:Stem=Down,Beam=First
|Note|Dur:8th|Pos:1^|Opts:Stem=Down,Beam=End
|Note|Dur:8th|Pos:1|Opts:Stem=Down,Beam=First
|Note|Dur:8th|Pos:1^|Opts:Stem=Down,Beam=End
|Bar
|Note|Dur:8th,Grace|Pos:1|Opts:Diminuendo|Visibility:Never
|Note|Dur:Half|Pos:1|Opts:Diminuendo,Muted
|User|Glissando.ms|Pos:1|Playback:Chromatic|Pen:wavy
|Note|Dur:8th,Grace|Pos:-7|Opts:Stem=Up,Muted|Visibility:Never
|Dynamic|Style:p|Opts:Velocity=127,Volume=45|Pos:-8
|Rest|Dur:Half
|Bar
!NoteWorthyComposerClip-End
Title: Re: Glissando.ms (2.11)
Post by: Marsu on 2018-06-22 04:04 pm
You need to use volume, not note velocity.
Ha. This sounds familiar to me. I may have read this some decades ago :)

Thanks Mike for creating that glissando, and Eric for enabling the object feature :D
Title: Re: Glissando.ms (2.11)
Post by: Peter Edwards on 2019-05-02 10:55 am
I've been notating glissandi that start part way through the duration of the initial note. This can be achieved by starting with a rest chord and inserting an invisible note at the desired position, but the playback isn't correct.

Would it be possible to add a parameter to delay the start of the glissando, both notationally and for playback? 
Title: Re: Glissando.ms (2.11)
Post by: Mike Shawaluk on 2019-05-02 11:21 am
According to Behind Bars, this would be achieved notationally by shortening the line. You can do this by using the Start Offset X and Start Offset Y parameters.

Originally when I created the Glissando object, I had no idea that it would ever be able to achieve playback. The playback code currently handles a number of playback options, and has gotten fairly complex; I don't think it will ever be able to achieve every possible playback contingency. For the time being, you may be better off using the standard NWC "tricks" for glissando playback, for your particular situation. If you do come up with a sample score that does what you want, please share it here and I can attempt to model that behavior within the plugin code.

Thanks,
Mike
Title: Re: Glissando.ms (2.11)
Post by: Flurmy on 2019-05-02 07:37 pm
I was able to do that, but I don't remember where and how.
I'll try to find out. It wasn't so long ago.
Title: Re: Glissando.ms (2.11)
Post by: Flurmy on 2019-05-02 08:12 pm
Ok, got it!
https://forum.noteworthycomposer.com/?topic=9877.0 (https://forum.noteworthycomposer.com/?topic=9877.0)
And the result is:
Code: (nwc) [Select · Download]
!NoteWorthyComposer(2.751)
|Editor|ActiveStaff:1|CaretIndex:37|SelectIndex:1|CaretPos:-2
|SongInfo|Title:""|Author:""|Lyricist:""|Copyright1:""|Copyright2:""
|PgSetup|StaffSize:16|Zoom:4|TitlePage:Y|JustifyVertically:Y|PrintSystemSepMark:N|ExtendLastSystem:N|DurationPadding:Y|PageNumbers:0|StaffLabels:None|BarNumbers:None|StartingBar:1
|Font|Style:StaffItalic|Typeface:"Times New Roman"|Size:10|Bold:Y|Italic:Y|CharSet:0
|Font|Style:StaffBold|Typeface:"Times New Roman"|Size:8|Bold:Y|Italic:N|CharSet:0
|Font|Style:StaffLyric|Typeface:"Times New Roman"|Size:7.2|Bold:N|Italic:N|CharSet:0
|Font|Style:PageTitleText|Typeface:"Times New Roman"|Size:24|Bold:Y|Italic:N|CharSet:0
|Font|Style:PageText|Typeface:"Times New Roman"|Size:12|Bold:N|Italic:N|CharSet:0
|Font|Style:PageSmallText|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User1|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User2|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User3|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User4|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User5|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User6|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|PgMargins|Left:1.27|Top:1.27|Right:1.27|Bottom:1.27|Mirror:N
|AddStaff|Name:"Staff"|Group:"Standard"
|StaffProperties|EndingBar:Section Close|Visible:Y|BoundaryTop:12|BoundaryBottom:12|Lines:5|Color:Default
|StaffProperties|Muted:N|Volume:127|StereoPan:64|Device:0|Channel:1
|StaffInstrument|Name:"Violin"|Patch:40|Trans:0|BendRange:24|DynVel:10,30,45,60,75,92,108,127
|Clef|Type:Treble
|Key|Signature:Bb,Eb,Ab|Tonic:E
|Dynamic|Style:ff|Pos:-8
|Note|Dur:8th|Pos:12|Opts:Stem=Down
|Note|Dur:4th|Pos:12^|Opts:Stem=Down
|Bar
|Note|Dur:8th|Pos:12|Opts:Stem=Down
|Note|Dur:4th|Pos:12^|Opts:Stem=Down
|Bar
|Note|Dur:8th|Pos:12|Opts:Stem=Down
|Note|Dur:4th|Pos:12^|Opts:Stem=Down
|Bar
|Note|Dur:8th|Pos:12|Opts:Stem=Down
|Note|Dur:8th,Slur|Pos:12^|Opts:Stem=Down,Diminuendo|Visibility:Never
|Note|Dur:8th,Slur|Pos:12|Opts:Stem=Down,Diminuendo,StemLength=0
|User|Markup.rg|Pos:12.5|Markup:/f1/x0/y-2.4/c124/y-4.4/c124/y-6.4/c124/y-8.4/c124/y-10.4/c124/y-12.4/c124
|Spacer|Width:450
|User|Glissando.ms|Pos:0|Playback:PitchBend
|Note|Dur:8th,Grace|Pos:4|Opts:Diminuendo,Muted|Visibility:Never
|Bar|Style:Double
|Dynamic|Style:mf|Pos:-10.5
|Note|Dur:8th,Slur|Pos:n0|Opts:Stem=Down,Beam=First
|Note|Dur:8th,Slur|Pos:1|Opts:Stem=Down,Beam
|PerformanceStyle|Style:Espressivo|Pos:-9.5
|Note|Dur:8th|Pos:2|Opts:Stem=Down,Beam=End
|Bar
|Note|Dur:8th,Slur|Pos:4|Opts:Stem=Down,Beam=First
|Note|Dur:8th,Slur|Pos:3|Opts:Stem=Down,Beam
|Note|Dur:8th|Pos:2|Opts:Stem=Down,Beam=End
|Bar
|Note|Dur:8th,Slur|Pos:1|Opts:Stem=Down,Beam=First
|Note|Dur:16th,Slur|Pos:b0|Opts:Stem=Down,Beam
|Note|Dur:16th,Slur|Pos:1|Opts:Stem=Down,Beam
|Note|Dur:16th,Slur|Pos:0|Opts:Stem=Down,Beam
|Note|Dur:16th|Pos:b-1|Opts:Stem=Down,Beam=End
|Bar|Style:Double
!NoteWorthyComposer-End
"With a little help from my friends"... (Rick)
Title: Removing the attack at the end of glissando
Post by: Flurmy on 2019-06-02 05:28 pm
How can I remove the attack of the note at the end of glissando?

Code: (nwc) [Select · Download]
!NoteWorthyComposer(2.751)
|Editor|ActiveStaff:1|CaretIndex:1|CaretPos:0
|SongInfo|Title:""|Author:"<Name>"|Lyricist:""|Copyright1:"Copyright © 2019 <Name>"|Copyright2:"All Rights Reserved"
|PgSetup|StaffSize:16|Zoom:4|TitlePage:Y|JustifyVertically:Y|PrintSystemSepMark:N|ExtendLastSystem:N|DurationPadding:Y|PageNumbers:0|StaffLabels:None|BarNumbers:None|StartingBar:1
|Font|Style:StaffItalic|Typeface:"Times New Roman"|Size:10|Bold:Y|Italic:Y|CharSet:0
|Font|Style:StaffBold|Typeface:"Times New Roman"|Size:8|Bold:Y|Italic:N|CharSet:0
|Font|Style:StaffLyric|Typeface:"Times New Roman"|Size:7.2|Bold:N|Italic:N|CharSet:0
|Font|Style:PageTitleText|Typeface:"Times New Roman"|Size:24|Bold:Y|Italic:N|CharSet:0
|Font|Style:PageText|Typeface:"Times New Roman"|Size:12|Bold:N|Italic:N|CharSet:0
|Font|Style:PageSmallText|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User1|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User2|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User3|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User4|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User5|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|Font|Style:User6|Typeface:"Times New Roman"|Size:8|Bold:N|Italic:N|CharSet:0
|PgMargins|Left:1.27|Top:1.27|Right:1.27|Bottom:1.27|Mirror:N
|AddStaff|Name:"Staff"|Group:"Standard"
|StaffProperties|EndingBar:Section Close|Visible:Y|BoundaryTop:12|BoundaryBottom:12|Lines:5|Color:Default
|StaffProperties|Muted:N|Volume:127|StereoPan:64|Device:0|Channel:1
|StaffInstrument|Name:"Recorder"|Patch:74|Trans:0|BendRange:24|DynVel:10,30,45,60,75,92,108,127
|Clef|Type:Treble
|Tempo|Base:Quarter Dotted|Tempo:88|Pos:12
|Key|Signature:F#|Tonic:G
|TimeSig|Signature:6/8
|Note|Dur:Half|Pos:2^
|Marker|Pos:6|Target:Articulation|Visibility:Never
|Note|Dur:4th,Tenuto|Pos:2
|User|Glissando.ms|Pos:0|Class:Span|Playback:PitchBend
|Bar
|Note|Dur:Half,Dotted|Pos:3^
|Bar
|Note|Dur:Half,Dotted|Pos:3
!NoteWorthyComposer-End
Title: Re: Removing the attack at the end of glissando
Post by: Rick G. on 2019-06-02 07:19 pm
How can I remove the attack of the note at the end of glissando?
Code: (nwc) [Select · Download]
!NoteWorthyComposer(2.751)
|AddStaff|Name:"Staff"
|StaffInstrument|Name:"Recorder"|Patch:74|BendRange:24
|Clef|Type:Treble
|Tempo|Base:Quarter Dotted|Tempo:88|Pos:12
|Key|Signature:F#|Tonic:G
|TimeSig|Signature:6/8
|Note|Dur:Half|Pos:2^
|Note|Dur:4th|Pos:2|Opts:Muted
|User|Glissando.ms|Pos:0|Playback:PitchBend
|Bar
|MPC|Controller:pitch|Style:Absolute|TimeRes:Eighth|SweepRes:32|Pt1:0,8875|Pt2:12,8192|Pos:8
|Note|Dur:Half,Dotted|Pos:3^|Opts:Muted
|Bar
|RestChord|Dur:Half|Opts:Stem=Up,Muted,HideRest|Dur2:Half,Dotted|Pos2:3
|Rest|Dur:8th,Dotted|Visibility:Never
|Note|Dur:4th,Grace|Pos:2^|Opts:Muted|Visibility:Never
|Note|Dur:4th,Grace|Pos:2|Visibility:Never
|Rest|Dur:16th|Visibility:Never
!NoteWorthyComposer-End
Title: Re: Glissando.ms (2.11)
Post by: Flurmy on 2019-06-02 08:10 pm
Rick the wizard, of course. Who else?  ;)
Thank you, Rick!